Neve…

Hoje o dia foi de neve. Por quase todo o país caiu neve…

Já estava a par da mais que anunciada descida das temperaturas anunciadas na comunicação social.

Quando abri a TV pela manhã, anunciavam na SIC Noticias que a A1 estava cortada a seguir a Santarém devido a estar a nevar em Torres Novas / Fátima.

Curiosamente foi a chamada da minha mãe que me alertou: “Olha está a nevar aqui”… nevar na Póvoa de Santarém, quem diria. Depois rapidamente pelo MSN me diziam: “Epá está a nevar em Santarém”. E assim foi, a Ângela enviou-me umas fotos.

Mais pela tarde já se dizia: “está a nevar em Lisboa”. O meu colega Bruno Santos dizia “Está a nevar em Lisboa, e aqui em Sintra”.

Infelizmente aqui no Monte cairam uns floquinhos, mas nada de neve em grande quantidade.

Infelizmente como a minha máquina não tinha pilhas não pude captar a foto de alguns flocos que vi. Apenas tirei esta com o Qtek, mas nada de especial se mostra… Vê-se um esbraquiçado que se via pela janela mais tarde.

Ainda mais tarde em conversa com a minha avó me dizia, que no Chouto, no concelo da Chamusca estava tudo branquinho…. Só se via branco. Já em Lisboa o meu padrinho confirmava que também nevava.

E foi assim o dia. Claro que é a noticia de todos os Telejornais do momento, e fotos dela aparecem em todos os blogs por este país. Bem aqui fica o meu tributo, à bela neve Branca.

Espero que amanhã não neve, e gostaria que não estivesse muito frio, para ver se não congelo :)

Ultimamente…

para variar não tenho colocado nada online. Bem a semana passada foi fim de semana de eleições, e na sexta feira (21 Janeiro se a memória não me falha rumámos até São Pedro de Moel). Divinal como habitual, frio em Janeiro, mas outra coisa não se esperava.

Casas vistas da praia

As casas vistas da praia.

O mar

O mar.

Pés

Claro que tinhamos de “brincar” pela areia….. As impressões digitais assim o comprovam.

Domingo foi altura de voltar para Lisboa, e claro, como não podia ainda tive um tempinho para passar pela Póvoa de Santarém e votar. Cumprir o meu dever civico.

Domingo pela noite foi dia de eleições, e no final ganhou o Prof. Cavaco Silva, com 50,59% dos votos. Não existiu uma segunda volta, e o segundo candidato mais votado foi Manuel Alegre com 20,72% dos votos. Cavaco arrecadou 2746689 e Manuel Alegre 1125077 votos.

Abaixo ficaram Mário Soares com 14,34%, Jerónimo de Sousa com 8,59%, Francisco Louçã com 5,31% e Garcia Pereira com 0,44%.

E foi assim que terminou mais uma louca corrida em Portugal, com 5531265 cidadãos a votar, de um total de 8835237 inscritos.

MP4 no Qtek

Qtek
Esta Sexta num jantar a que fui, tirei alguns videos com o meu Qtek S100, o qual têm Windows Mobile 2003 SE.
Ora após alguns testes lá consegui pôr aquilo a gravar, não esperava grande qualidade mas até tinha some tudo. Rapidamente puxei do SD Card de 128 MB que trago na carteira junto com o SD Wi-Fi que se coloca no slot SDIO do device, e toca a gravar.

Curiosamente pensei em formatar o Qtek que já vinha precisando. Ora tirei tudo o que precisava para o PC. A coisa mais gira foi não conseguir ler os belos dos videos no Windows.

Curiosamente, parece que o mp4 não é reconhecido pelo Windows. Instalei codecs Divx na esperança que resolvesse o problema e nada.

Hoje após algumas pesquisas e não sei bem porquê forcei o Media Player a ler o ficheiro e lá apareceu qualquer coisa, apesar dos protestos que o ficheiro não era reconhecido. Contudo nem mesmo assim o som apareceu.

Ainda conforme sugerido saquei o G-Spot para ver se me conseguia identificar eventuais codecs para este ficheiro mas nada…

A solução veio com o ABC 4 Video Converter que usei para converter os movies para avi com o codec DivX.

Estranho… pensei que estas coisas entre Windows fossem mais compativeis. Possivelmente há qualquer coisa que ando aqui a fazer mal, ou estou a avaliar mal :(

Seminário sobre Wimax em Portugal

Realiza-se a 31 de Janeiro, no Hotel Altis ParK, em Lisboa, um seminário sobre o panorama actual e o fututo do WiMax em Portugal, promovido pelo Institute for International Research (IIR). O programa integra seis módulos, entre os quais o novo cenário das conexões sem fios de banda larga, factores chave do mercado para o WiMaxX, o panorama actual e futuro do WiMax em Portugal.

Mais informações na página da Anacom

Apache & IIS on the same machine

Decidi republicar este post de um blog meu antigo visto que acho que a sua utilidade é extrema:

Já era algo curioso que andava a investigar a algum tempo para tentar resolver um pequeno problema que existe lá numa aplicação na empresa, e a verdade é que é mesmo possivel.

Aparentemente tudo apontava para ser possivel por cada um deles “em escuta” no porto 80 de um ip diferente. Infelizmente pelos testes realizados não o é. O nosso amigo IIS apodera-se de tudo o que é IP mesmo no IIS Admin especificando apenas o IP desejado.

De qualquer das formas após algum googling a resposta veio aqui:

http://p2p.wrox.com/topic.asp?TOPIC_ID=13366

Como geralmente estas coisas desaparecem passo a citar:
After installing Windows 2003, I configured IIS then turned off the service. Then I installed Apache and configured it to listen on the proper IP and port.

In this case the problem was that IIS 6.0 has a feature called Socket Pooling that claims all ports for all loaded IP addresses, even if not configured in IIS.

So, IIS was hogging port 80 on the IP address I’d designated as the Apache address and causing it to not run.

What I had to do was:

1- Extract the httpcfg.exe utility from the support tools area on the Win2003 CD.
2 – stop all IIS services: net stop http /y
3 – have IIS listen only on the IP address I’d designated for IIS: httpcfg set iplisten -i 192.168.1.253
4 – make sure: httpcfg query iplisten (the ip’s listed are the only ip addresses that IIS will be listening on and no other)
5- restart IIS Services: net start w3svc

Voila! Apache is listening on its default ports on 192.168.1.254 and IIS is listening on its default ports on 192.168.1.253.

E assim foi, apesar de não ter dado à primeira (não sei bem porquê o httpcfg devolveu um resultado 0 (como não o sei interpretar fiquei na dúvida), experimentei e o comportamente era o mesmo.
Lá fiz novamente o Stop ao w3svc, reconfigurei com o httpcfg, obtive um resultado 183 (deve ser melhor que 0, pensei eu), e um novo start aos serviços.

Testando lá temos o apache no Ip 1, e o IIS no IP 2. O Firefox não engana ! :)

E assim parece que ficam resolvidos os problemas de páginas com scriptings diferentes na mesma máquina. Nada de chamar php com IIS, e deixar a “natural performance” do apache tratar a “heavy load” bem como os php’s.

Claro que para os asp’s nada melhor que de quem deles sabe… IIS.